SDK Android

Pré-requisitos

Para que você consiga integrar com o SDK Android da Stone é necessário seguir alguns requisitos técnicos.

  • Nosso SDK é desenvolvido nativamente no sistema Android, por isso sua aplicação precisa ser Android também ou, caso ela seja desenvolvida com uma plataforma híbrida, é necessário uma interface ou plugin que permita essa comunicação.

  • Caso você esteja integrando no nosso SDK utilizando um:

    • Pinpad: sua aplicação precisa ter a versão do 4.0+ do Android (API 14)

Caso você queira utilizar os dois dispositivos, aconselhamos a usar o mecanismo de Flavors do Android.